Kuribo64
Views: 10,201,746 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
12-06-19 12:26 AM
Guest:

0 users reading Xane's Whitehole problems/errors | 1 bot

Main - Archived forums - SMG hacking tools development - Xane's Whitehole problems/errors New reply

Pages: 1 2
Xane123
Posted on 10-23-12 09:42 PM (rev. 2 of 10-23-12 09:42 PM) Link | #1053
EDIT: This was my fault. I was not selecting the exact folder.


'.' After starting Whitehole via the Windows launcher and choosing the ISO folder (the one that has the ObjectData and StageData folders directly inside it), this huge Java error appears in the command prompt while Whitehole itself says "Game directory successfully opened". I'm using Java SE 7 Update 9.

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
at whitehole.fileio.ExternalFilesystem.getDirectories(ExternalFilesystem.java:50)
at whitehole.smg.GameArchive.getGalaxies(GameArchive.java:47)
at whitehole.MainFrame.btnOpenGameActionPerformed(MainFrame.java:198)
at whitehole.MainFrame.access$100(MainFrame.java:29)
at whitehole.MainFrame$2.actionPerformed(MainFrame.java:79)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$200(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
o_O Even v0.9 has this same error.


____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

shibboleet
Posted on 10-23-12 09:54 PM Link | #1054
Are you sure you packed all the files correctly?
You should have JRE7 installed.


____________________
a

Xane123
Posted on 10-23-12 10:15 PM (rev. 4 of 10-23-12 10:54 PM) Link | #1055
Posted by Luigi
You should have JRE7 installed.

I have Java SE 7. I'll download JRE 7 then I'll edit this if I can get Whitehole working.

EDIT: I installed what said "JRE" but when I went to the "Check Java" page on Java's website it still said Java SE 7. I tried going to the control panel and clicking to uninstall "Java 7 Update 9" but when I did, it said "Close browsers", but I hit cancel and a message came up saying it would happen at next startup or something. I hit the "X" button and now I think I have glitched all the Java setups; When I click to uninstall them, a "Getting required information" message appears then the installation ends.

Is there another way I can remove Java so I can try the JRE 7 installation again?

:S EDIT 2: What does this page say your Java is? Does it say Java SE like mine does? (Mine says "Java SE Update 09" and "32-bit" even though I installed JRE 64-bit, since my computer is 64-bit)

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Dirbaio
Posted on 10-24-12 04:37 AM Link | #1056
"JRE 7" and "Java SE 7" is the same thing. It's the thing that you use to run Java programs. You should be fine with what you have.

About the error, I'm not sure what's going on. From looking at Whitehole's source, I see it's failing to list the files in a directory or something. Do you have weird folder permissions, or something?

Probably Arisotura knows more about what's going on :)

____________________
Cool Stuff: Dirbaio.net (my boring site) - The NSMB Hacking Domain - Kuribo64 - ABXD DevBoard

Xane123
Posted on 10-24-12 10:38 AM Link | #1057
Posted by Dirbaio
"JRE 7" and "Java SE 7" is the same thing. It's the thing that you use to run Java programs. You should be fine with what you have.

Cool. I wish I hadn't glitched Java as now I can't do any updates to it.

Posted by Dirbaio
About the error, I'm not sure what's going on. From looking at Whitehole's source, I see it's failing to list the files in a directory or something. Do you have weird folder permissions, or something?

I have it in a folder under my user folder in Windows 7 (/Super Mario Galaxy Hacking Kit/Whitehole) and I tried running it with normal and administrator privileges, only to see it still fail to load that list. Is there a certain place where I should put Whitehole? I give it the correct folder, by what I know (I double click on the folders after clicking the Game folder option, then when I select the game folder itself, I'd click it once and then click the Open button at the bottom of that ialog, which then makes this happen.

Also, does the last part mean I should PM Arisotura about this or ask him to have a look at this conversation? ^^;;;

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Dirbaio
Posted on 10-24-12 10:44 AM Link | #1058
What you should do is select the folder with the extracted ISO. So if you have "SMG/ObjectData" and "SMG/StageData", then you have to select the "SMG" folder.

If you're doing it that way, then I have no clue what's going wrong. Just wait until Arisotura sees this, he checks the forum every day.

:)

____________________
Cool Stuff: Dirbaio.net (my boring site) - The NSMB Hacking Domain - Kuribo64 - ABXD DevBoard

Xane123
Posted on 10-24-12 10:52 AM Link | #1059
I think those folders were in the folder since all my ISOs are in the ISOs folder, and inside the "ISOs/Super Mario Galaxy/files" directory, those two folders are there. I think I looked at that when I first tried.

I'll wait for Arisotura, I guess. I'll check my computer when I get on it for what's in those folders. Maybe the files aren't correctly placed? I thought ObjectData ddn't have folders but StageData did...I'll see later.
< offtopic > also, Dirbaio, how do you know when to perfectly come to my post to reply? A subscription? < /offtopic >

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Dirbaio
Posted on 10-24-12 11:09 AM Link | #1060
lol. It's because on IRC there's a bot that notifies of all new posts on the board instantly :)


____________________
Cool Stuff: Dirbaio.net (my boring site) - The NSMB Hacking Domain - Kuribo64 - ABXD DevBoard

Xane123
Posted on 10-24-12 12:25 PM Link | #1061
Posted by Dirbaio
lol. It's because on IRC there's a bot that notifies of all new posts on the board instantly :)

:up: OK, nice. I must be used to how Doomworld handles it, by e-mailing the first time someone posts while you're gone.

Well, hope I see Arisotura post here sometime; Surely he can find out the problem? '.'

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Arisotura
Posted on 10-24-12 02:25 PM Link | #1064
Well, are you selecting the ISO folder right? The way Whitehole makes you select the folder may seem unusual because it looks like a file picker, but there's not much I can do for that...

You need to select the folder that contains your ObjectData and StageData folders, by clicking it once, and then click Open. It is important that you click the folder once and don't enter it.

Also, make sure to have the ObjectData and StageData folders with all the files needed. And make sure that the folders/files aren't read-only.

This is the best I can suggest. The exception message suggests that Whitehole tried to enumerate folders in a folder that doesn't exist, or something similar, but can't tell for sure. I really need to add proper error reporting...

____________________
NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is

zafkflzdasd

Xane123
Posted on 10-24-12 04:04 PM Link | #1065
Ugh, this is my fault. I wasn't selecting the correct folder after all; I was selecting the "Super Mario Galaxy" folder, not the "files" folder, which has the folders in it. I don't now why I didn't double-check when the previous replies told me this.

Seriously, I don't know why I didn't try this before. Could you remove this thread as it isn't a problem? Still, thank you all for explaining I might've not been selecting the right folder.

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Arisotura
Posted on 10-24-12 04:47 PM Link | #1066
Nah, I'll keep this thread as a reminder that I need to implement proper error handling :)

It can also be useful if other people are having the same issue. This, provided that said people can search, of course.

Anyway, glad that we resolved the issue.

____________________
NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is

zafkflzdasd

Xane123
Posted on 10-24-12 05:07 PM Link | #1067
Yeah.

< offtopic> The editor's cool, but there isn't a zoom feature (in the readme). Oh well. Good job, Mega-Mario/whoever else helped. Also, I'll try to name planets in the Object Database, as the default internal names are weird. < /offtopic >

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Arisotura
Posted on 10-24-12 05:08 PM Link | #1068
There's a zoom. Use your mouse's scrollwheel. Oh and if you don't have a scrollwheel, for now you're kinda screwed, but I'll try to remedy this in the next release.

Also, if you're going to help with the ObjectDB, make sure to read this before :)

____________________
NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is

zafkflzdasd

Xane123
Posted on 10-24-12 05:50 PM (rev. 3 of 10-24-12 05:58 PM) Link | #1070
I'm using a laptop, so I have to rotate/move until I get close to something. I wonder what the next release will do, possibly requiring CTRL+right mouse or something. Well, knowing you, you'll figure it out.

Also, read about the ObjectDB. I left the two checkboxes checked on this because it doesn't appear to have any special properties, being a planet.

EDIT 1: I have another Java error. Can I post it? It'd still be on-topic.

EDIT 2: Fixed URL tag.

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Arisotura
Posted on 10-24-12 05:57 PM Link | #1072
Go ahead.

Also I just saw your ObjectDB edit. Good. Continue this way :)

____________________
NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is

zafkflzdasd

Xane123
Posted on 10-24-12 06:01 PM Link | #1073
OK. This appears when I start deleting objects in Good Egg Galaxy (although the location probably doesn't metter). When I'm deleting objects, sometimes the one I'm selecting will disappear when I click delete (which is normal), but other times, the object will not disappear from the list.

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
at whitehole.smg.LevelObject.render(LevelObject.java:192)
at whitehole.GalaxyEditorForm$GalaxyRenderer.renderSelectHighlight(GalaxyEditorForm.java:1199)
at whitehole.GalaxyEditorForm$GalaxyRenderer.prerenderZone(GalaxyEditorForm.java:1303)
at whitehole.GalaxyEditorForm$GalaxyRenderer.doRerenderTasks(GalaxyEditorForm.java:1415)
at whitehole.GalaxyEditorForm$GalaxyRenderer.display(GalaxyEditorForm.java:1460)
at jogamp.opengl.GLDrawableHelper.displayImpl(GLDrawableHelper.java:189)
at jogamp.opengl.GLDrawableHelper.display(GLDrawableHelper.java:177)
at javax.media.opengl.awt.GLCanvas$7.run(GLCanvas.java:853)
at jogamp.opengl.GLDrawableHelper.invokeGLImpl(GLDrawableHelper.java:425)
at jogamp.opengl.GLDrawableHelper.invokeGL(GLDrawableHelper.java:364)
at javax.media.opengl.awt.GLCanvas$9.run(GLCanvas.java:868)
at javax.media.opengl.Threading.invoke(Threading.java:193)
at javax.media.opengl.awt.GLCanvas.display(GLCanvas.java:405)
at javax.media.opengl.awt.GLCanvas.paint(GLCanvas.java:482)
at javax.media.opengl.awt.GLCanvas.update(GLCanvas.java:635)
at sun.awt.RepaintArea.updateComponent(Unknown Source)
at sun.awt.RepaintArea.paint(Unknown Source)
at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$200(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Arisotura
Posted on 10-24-12 06:06 PM Link | #1074
Oh, I thought I had fixed that kind of glitches when removing objects. Normally the object should be deleted regardless of the visual result. If it remains in the object list or the 3D view, I'd say ignore it, trying to mess with the ghost object could cause more problems.

Simply selecting another object in the same zone should get rid of the ghost.

I'll look into this kind of issues for the next release. Damn, I was sure it worked correctly...

____________________
NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is

zafkflzdasd

Xane123
Posted on 10-24-12 06:11 PM (rev. 2 of 10-25-12 10:51 AM) Link | #1075
Well, good luck. :up: I might just move objects around until then, as working around the limitations in Good Egg Galaxy's gonna be hard. I hope you also implement paths sometime. Can't wait for launch stars shooting me everywhere. Those error messsges make me concerned when I see them, bringing back bad memories of when the first error occurred.

ADDITION: Last night, after. Had gotten those errors when deleting objects, I started over by copying the original fles from the ISO. This time around, I avoided deleting any objects. Everyting appeared to work fine until I started switching some objects' zones and layers. (I will have to try again and wach what I move to what layers, since I don't know what layers do and what specifc layers they have to be in)

I placed a planet from Gusty Garden and also moved the sling star, not changing layers on probably all the objects I moved. I also moved the "blue sky" object from a nearby planet by changing its zone to the current one I was working on.

By this time, the command prompt started showing errors. After I added a pull star (which is hard to move due to how skinny it is on the sides) and then I saved yet again. '_'

After going through the intro and "blasting off" to the Good Egg Galaxy, the game froze at the star selection screen. Upon loading the level back in Whitehole, most of the objects were erased in the zone I was working in, everything else untouched. Even the "intro blasting in" object was removed in the process. Is there something wrong I'm doing with zones/layers? >_>

Also, to keep this on-topic, I'll rename this topic to "Xane's problems". Maybe if the first error I posted is important info, this can be stickied or something? It showed how I failed to read instructions. :ninja:

____________________
Doom II: The Monster Invasion | Doomworld | YouTube | Twitter

Posted by ray
I HATE IT, if you need to register to view soemthing :c THATS CRAP

Arisotura
Posted on 10-25-12 11:05 AM Link | #1077
That's truly weird. Whitehole shouldn't misfunction that badly, it has been tested before release and everything worked fine...

What'd interest me is the errors that the terminal spits out.

____________________
NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is

zafkflzdasd
Pages: 1 2

Main - Archived forums - SMG hacking tools development - Xane's Whitehole problems/errors New reply

Page rendered in 0.035 seconds. (2048KB of memory used)
MySQL - queries: 30, rows: 237/237, time: 0.017 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.