Kuribo64
Views: 17,217,257 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
06-27-22 02:59 PM
Guest:

0 users reading SMG2 questions | 1 bot

Main - Misc. ROM hacking - SMG2 questions Hide post layouts | New reply


Taycamgame
Posted on 10-19-20 07:51 AM (rev. 2 of 10-19-20 07:57 AM) Link | #99685
So I made an edit of Flip-Swap Galaxy. Removed all the chomps, the electric fences, npcs, paths that are now not used, changed positions of (and added) a bunch of the platforms.
In other words, the only objects in the level now are a bunch of the purple block platforms, the flip swap platforms, the Mario spawns, the Luigi ghost thing (idk if I should remove that so i didn't), the comet medal, the checkpoint and the stars (I moved the position of Green Star 1 so far).

When i test the level, the game crashes (testing via Dolphin Emulator), I get an "Invalid write #(string) to PC:#(string)". I'm not sure what I broke, I removed all the objects that would require paths (except the galaxy fly in), I didn't touch any of the Areas either.

Not sure if there's anything I've possibly missed when creating the level, thoughts?

(I'll upload the level if needed)

Lavalinater9000
Posted on 10-19-20 11:25 AM (rev. 4 of 10-19-20 11:42 AM) Link | #99686
Hmmm.....if you could, can you upload it, since i think i know a fix, but i need to take a closer look. Since i have had multiple crashes with galaxy's i edited and i generally have things that i use to find a fix....(i have edited so many non-redblueexgalaxy galaxy's xp)


before you do it....you said, purple block platforms.....are you refering to the "repeatblock" or the snakeblock? cause if you are using them....they "Require" Paths in order to work, and im pretty sure if they don't have paths then they won't work, but i would like to see if i can get your level to work. Since i think i might be able to.

Taycamgame
Posted on 10-19-20 12:01 PM Link | #99688
By purple blocks I mean the static platforms that appear in Flip Swap galaxy.
I also edited the level a bit since the OP. Added a launch star (with paths), removed a few "areas" that I don't need such as a few switch areas. Added more flip platforms.
I'll upload the level later when I get back to my computer.

Snarky Sceptile
Posted on 10-19-20 01:56 PM Link | #99689
I have found from my personal experience that just deleting everything in Flip-Swap does lead to a crash. I'm not entirely sure what the cause is but I think I'd have to blame it on "RailObj", which is placed in MapParts, a seperate folder (or something like that). Once I deleted those my game kept crashing and I had to start my level all over :(
So if RailObj's are still in your level and you didn't touch any of them, then I am out of ideas.
And I don't think there would be a solution/way to fix it if you did delete them and it is indeed the cause. Unless you found a way to delete their remains in other folders, or somehow placed functioning RailObj's, you are going to have to restart.

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
Posted on 10-19-20 03:27 PM (rev. 3 of 10-19-20 06:54 PM) Link | #99690
When you say RailObj, do you mean the electric moving things? If so, I did delete them, because I didn't actually want to use them in the level. I have no idea how SMG2 handles them but that seems like a pretty specific thing to cause a crash. Is that the only object in Flip Swap that cannot be deleted without causing a crash?

Also, what do you recommend I do to "remove" the rails? Move them far away? Move the level away from them? Use a different galaxy that doesn't have them at all?

EDIT:

After resetting the level, I realised what you meant by the rails - those seem to be the paths that the electric fences follow. So deleting the electric fences works, fortunately.
Hopefully I should be good to go now!



Two more things (unrelated but i'd rather not create a new thread just to ask), is every galaxy required to have that Luigi ghost object? The one that appears near the start of the level.

Second, about the Green Star missions. There are two scenarios in flip swap with a number beside them which I assume are the green star missions. However, the green star objects actually appear in the first scenario. What's up with this?

Snarky Sceptile
Posted on 10-19-20 11:42 PM (rev. 3 of 10-20-20 02:12 AM) Link | #99694
I am pretty sure that no galaxy is required to have a Ghost Luigi by any means. I know that every folder has a file called "(Galaxy Name).Ghost.arc" or something like that, and I cannot confirm that that controls the Ghost Luigi but I can guess that it does.
(So maybe if you did delete Ghost Luigi and that file you could get rid of it. Can't confirm this won't cause a crash though. I should actually try this myself...)

For the green stars I think they only appear in mission 1 because they are on LayerA. Assuming that is what you want clarified.

EDIT: Yup I was right. https://kuribo64.net/wiki/?page=SMG_Stage_Filesystem_

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
Posted on 10-20-20 07:12 PM (rev. 2 of 10-20-20 10:36 PM) Link | #99696
Do LayerA objects appear in Scenario 1 always? What about other scenarios / layers?

Also, I have a launch star setup. It works fine and takes me to the destination, however upon landing, Mario slides a small distance. Is there a way to fix this?

Snarky Sceptile
Posted on 10-21-20 02:05 AM Link | #99699
Layers work something like this: the way the level is designed, certain objects only appear in certain loads. These loads are triggered by events, which is almost always the star select. Nintendo sets up the level so for example, when you select star 1, everything on its associated layer (usually LayerA) are loaded. Some objects may be triggered on other layers (Flip-Swap Galaxy's other layer is Layer P, accessed by the comet mission), and some are triggered on ALL layers (called "Common"). Green Stars work on their own layer (kind of), you select the Green Star mission on Star Select and it loads everything on that mission plus the Green Stars, which is why you never see them before 120 stars.

Sliding from a Launch star... my only guess for that is that you land at a very steep angle near parallel to the platform, maybe try setting up the path so Mario lands on it straight down? If you are doing it straight up already I can't help you there.

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
(post deleted) #99703

Taycamgame
Posted on 10-24-20 11:04 PM Link | #99749
By the way, I'm trying to use objects from Galaxy 1 in my levels. However, in Whitehole they just show up as blue boxes (but in the object list they appear with the proper name). Is there something I can do to make the objects actually show up?


Last thing as well, I tried adding music but the game crashed. Is it only possible to replace existing music files?

Snarky Sceptile
Posted on 10-25-20 04:31 PM Link | #99752
Sorry, I only know how to replace existing music files. I'm still new to modding and don't know how to do anything outside of the base game.
For the blue box thing, that means they don't have a model. I have found just placing those will crash the game 99% of the time, so that means there is some data missing. I think you'd have to actually code/fix some stuff since the objects are only partially completed.

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
Posted on 10-25-20 06:08 PM (rev. 2 of 10-25-20 06:10 PM) Link | #99753
Also I'm having an issue with editing gravity.

I have two of the same type (Pointed) gravity. They are supposed to have the same size, I'm using them for a "pathway" of rocky planets. Anyway, the issue is that when I edit the properties of one of the gravity zones, the other one disappears. I have other gravity zones (including a third pointed one of a different size), but none of those disappear.

How do I stop this from happening?

Snarky Sceptile
Posted on 10-25-20 09:15 PM Link | #99754
hmm... identity crisis? (Meaning: do they share an object ID?)

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
Posted on 10-25-20 11:06 PM Link | #99756
Nope. However the issue fixes itself if I close and reopen the file. Still weird nonetheless.

Taycamgame
Posted on 10-28-20 11:26 PM Link | #99769
Sorry for the double post, but I doubt this would get seen otherwise:

I used Dossun2 to edit the scenario file for Flip Swap Galaxy. I renamed scenario 1 from パタパタパニック! スピン! スピン! to "Burning Lava" (name WIP). The name shows up fine in both Dossun2 and Whitehole. However, when I test the level, it ignores my updated name and simply shows "Think Before You Shake".

Is there something I'm missing which is required to properly rename scenarios (or any files in general)? Is there something else that stores the names which are actually shown in-game?

Snarky Sceptile
Posted on 10-29-20 12:36 AM Link | #99770
Did you press the save button

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
Posted on 10-29-20 12:39 AM Link | #99771
Posted by Snarky Sceptile
Did you press the save button


Yeah.
I think you have to edit the ScenarioName.msbt thing which contains all the translated names of the scenarios.

So I extracted it from SystemMessage.arc and changed the name within, but how do I put ScenarioName.msbt back into SystemMessage.arc?

Snarky Sceptile
Posted on 10-29-20 12:57 AM Link | #99772
I don't know. I personally changed text via Whitehole's msbt editor and it works fine. I know nothing on Dossun2.

____________________
Heh... how hilarious.

Current project: Spring Mario Galaxy 2 (It's exactly what it sounds like. Production of this mod will have to slow down a bit due to other things Sadge)
Galaxies finished: 11/49

Taycamgame
Posted on 10-29-20 01:02 AM (rev. 4 of 10-29-20 01:50 PM) Link | #99773
Which file(s) did you need to change (via the whitehole method you used)?

Edit: Nevermind, I believe I found it.

The MSBT / BCSV editor is a tad tricky to use, since you are basically required to know the names of the files within the .arcs.

Edit 2:

So I followed the Porting Galaxies guide on this forum. Ported the galaxy from Flip-Swap to Melty Monster fine-ish, except in Whitehole I can't see the galaxy anymore unless I click on "Zones: Edit Individually" on the galaxy zone. Not really sure what went wrong.

If it helps, I've uploaded the level here: https://kuribo64.net/get.php?id=Vc5QQMHdxp1fziON


Main - Misc. ROM hacking - SMG2 questions Hide post layouts | New reply

Page rendered in 0.028 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 233/233, time: 0.009 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.