Views: 17,219,251 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
06-27-22 10:05 PM

0 users reading CLPS help | 1 bot

Main - General SM64DS hacking - CLPS help Hide post layouts | New reply

Posted on 07-07-16 09:25 PM Link | #73062
Hello. I apologize in advance if this has already been answered or if I'm asking in the wrong place.
I'm trying to make the water texture in my level act like water. I've assigned it to collision ID 2, which is the same ID that the water in the castle backyard is set to, but the water only acts as solid ground on the surface. From what I've read, I need to use the CLPS editor, but I've no idea how it works or what the numbers mean.

Posted on 07-08-16 03:15 AM Link | #73089
When you open your model in the level importer, you should see this in the bottom left corner:
(image didn't show up properly so I linked you to it)
When you see what you named your water, you need to give it a value other than 0. So just give it like 1 or something as long as it's not huge. Then click "Assign Types" and import your level. Once that's done go into the CLPS Editor and go under the number you assigned the water to: http://imgur.com/a/4lfl5
(image didn't show up properly again)
In my case I chose 1 so I went to 1 and I clicked the "Type/Description" of 1: [image]
Click it and locate "Water". Once you have water selected, close the CLPS editor save your level. You are done. The same is done when you want to import such things like lava, quicksand, hills, etc. If there is a part I did not make clear let me know. I'm more than happy to help! :D Also not to backseat moderator by any means. But I think you are supposed to post such questions in the SM64DS help thread.

Posted on 07-08-16 03:52 AM (rev. 2 of 07-08-16 03:54 AM) Link | #73093
Thank you for the reply. I was able to follow your explanation well, but unfortunately nothing has changed. I don't suppose the CLPS editor is -intended- to change the values you've typed in? If I select "water" then it changes the third and fourth columns to 0. If I change it back to 2 (the number I've chosen for water), the "water" option changes back to "other/unkown". There must be something I'm not understanding correctly.
Also, sorry for not posting my question in the correct place. I'll remember for next time.

Posted on 07-08-16 03:33 PM (rev. 2 of 07-12-16 05:22 AM) Link | #73185
That actually happened to me the other day. And it went away when I closed and re-opened the editor. Maybe try doing that.

EDIT: Did you hit enter after you selected the correct terrain? If so then it's an editor problem and try downloading a more recent version if you don't have it already.

Posted on 07-09-16 03:41 AM (rev. 3 of 07-10-16 02:43 AM) Link | #73202
Nope. That hasn't made a difference. Choosing "water" just changes all the values to 0 and the left-most value to 244. Could it be an unintentional effect in the version of the editor I'm using?

I've tried as many different things as I can, and unfortunately I've come to the conclusion that the game has become sentient and decided that it doesn't want to cooperate. Nothing has worked, and the water remains a solid surface. I suppose I'll just have to do without it then. :\

Posted on 06-20-18 02:41 AM Link | #94787
Please see this document: https://docs.google.com/document/d/11tHJ77km4EPITucU9RMdhW5ImPEvCyxPxUAbxqzm6Ks/edit

check out my CLPS Document: https://docs.google.com/document/d/11tHJ77km4EPITucU9RMdhW5ImPEvCyxPxUAbxqzm6Ks/edit

Main - General SM64DS hacking - CLPS help Hide post layouts | New reply

Page rendered in 0.015 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 207/207, time: 0.008 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.