Kuribo64
Views: 14,728,695 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
06-19-21 11:01 AM
Guest:

0 users reading Editor development | 1 bot

Main - General SM64DS hacking - Editor development New reply

Pages: 1 2 3 4 5 ... 9 10 11 12 13 14 15 16 17 ... 27 28 29 30 31
Hiccup
Posted on 12-31-13 12:25 PM Link | #36998
Thanks for the build and the information!

Jesse
Posted on 12-31-13 02:02 PM Link | #37000
so I thought: yay lets import a .dae cuz there are yet two versions with fixed problems. so I imported it and saw nothing. I thought maybe its the scale, so I write another scale: then I see mario is going to another position. so with the scale option you can chance marios position on the x y as xD

I hope you can do something with this story : )

skyl
Posted on 12-31-13 02:12 PM Link | #37001
Actually, it changes the model's position, not mario's...

____________________
Can you burn a Luigi board?

Fiachra
Posted on 12-31-13 02:19 PM Link | #37002
"so with the scale option you can chance marios position on the x y" - You probably just moved Mario with your mouse.

"Actually, it changes the model's position, not mario's... " - It doesn't change the position of anything. Your model may not be centered in which case it might look that way?

"so I imported it and saw nothing" -
Have you applied the model's scale within your editing program?

What program are you using to export the DAE model? If it's Blender there are a few things you may need to do to get it to export correctly.

Jesse
Posted on 12-31-13 04:42 PM Link | #37010
Posted by Fiachra
"so with the scale option you can chance marios position on the x y" - You probably just moved Mario with your mouse.

"Actually, it changes the model's position, not mario's... " - It doesn't change the position of anything. Your model may not be centered in which case it might look that way?

"so I imported it and saw nothing" -
Have you applied the model's scale within your editing program?

What program are you using to export the DAE model? If it's Blender there are a few things you may need to do to get it to export correctly.


1. yes it chances mario's position, I wanted that there was a way so I could show it to you. it is really weird.

2. see 1

3. I thought it was the normal size.

4. I think here is the mistake, I use blender.

but that mario's position chances while editing the scale must be a sort of bug.

skyl
Posted on 12-31-13 05:40 PM Link | #37014
Posted by jjesss064
Posted by Fiachra
"so with the scale option you can chance marios position on the x y" - You probably just moved Mario with your mouse.

"Actually, it changes the model's position, not mario's... " - It doesn't change the position of anything. Your model may not be centered in which case it might look that way?

"so I imported it and saw nothing" -
Have you applied the model's scale within your editing program?

What program are you using to export the DAE model? If it's Blender there are a few things you may need to do to get it to export correctly.


1. yes it chances mario's position, I wanted that there was a way so I could show it to you. it is really weird.

2. see 1

3. I thought it was the normal size.

4. I think here is the mistake, I use blender.

but that mario's position chances while editing the scale must be a sort of bug.


If the model is not centered it appears to change mario's position but it's actually the model moving if you change the scale.

____________________
Can you burn a Luigi board?

Skelux
Posted on 01-01-14 04:00 AM Link | #37047
The first byte of the second word in the CLPS entry is the path ID used for wind. Thanks, I have it working now.

Fiachra
Posted on 01-01-14 05:58 AM Link | #37048
skyluigi and jjess064: Individual co-ordinates' positions move outward from the centre when scaled but the model's position is still (0,0).

[image]

jjess064/Anyone looking to export DAE with Blender:
For exporting using Blender (I'm using 2.68a):
- Each texture must have its own Material with and have an assigned Texture (Video I made for someone else). The quickest way for an already-textured model is to select a face with a specific texture, Select>Similar>Image and then assign that to a new material and add the Texture as shown in the video. Do this for each texture used.
- Object mode, Object>Apply>Location, >Rotation, >Scale. This is in case you've scaled it down a lot, it will appear one size but when exported will have the original scale.
- Sometimes the exported DAE model will be rotated, usually on the X axis. Eg. if rotated on X axis by 90 degrees: Object mode, type "RX-90", Object>Apply>Rotation. Now export. You can then do RX90 and don't apply rotation. Now it'll look right when editing and exporting.
- File>Export>Collada DAE Do select 'Include Material Textures' (otherwise textures don't get exported), do not select 'Copy' (this would create copies of all your images).

Does it appear if you export as OBJ?

Skelux: That's good. I'll see if I can add to the CLPS editor descriptions entries, eg. if you selected that wind entry from the drop-down you'd get a description (tooltip maybe) for the different bytes.

Jesse
Posted on 01-01-14 06:44 AM Link | #37049
when I select Include Material Textures nothing will be exported(only the .dae of course) however when I select copy it works.

Fiachra
Posted on 01-01-14 06:51 AM Link | #37050
Posted by jjesss064
when I select Include Material Textures nothing will be exported(only the .dae of course) however when I select copy it works.


"...when I select copy it works" - What do mean by "works", do you mean you can import it?

Can you open your exported DAE file in another 3D editor/viewer eg. MeshLab. If the textures appear correctly it should be fine.

Jesse
Posted on 01-01-14 07:17 AM (rev. 3 of 01-01-14 08:26 AM) Link | #37051
I mean that if I don't do "copy" that the importer says that there are missing textures. it makes sense and it works now

edit:

[image]
it seems that I get this error suddenly.

Fiachra
Posted on 01-01-14 10:29 AM (rev. 2 of 01-01-14 10:29 AM) Link | #37055
"Input string was not in a correct format"

Does your DAE file contain decimal commas instead of decimal points, eg. 1,234 instead of 1.234? If so, can you open your DAE file and replace all commas with decimal points.

Have you changed any settings in Blender?
Have you modified your DAE file after exporting?

"it seems that I get this error suddenly." - Did you change anything?

Can you please translate the main error in future.

Jesse
Posted on 01-01-14 11:24 AM Link | #37059
no I really haven't chanced anything after or before the exporting its just total random. however must every material have his own object? oh and everything is just in .

Fiachra
Posted on 01-01-14 11:34 AM (rev. 2 of 01-01-14 11:41 AM) Link | #37060
Can you answer "Does your DAE file contain decimal commas instead of decimal points"?
Do a search for "float_array" or "" (remove speech marks).

"however must every material have his own object?" No, I said every texture must have its own material.

"oh and everything is just in" I don't understand what you mean.

Jesse
Posted on 01-01-14 01:19 PM Link | #37067
everything is in decimal points.

I don't know exactly what you mean but I saw .

oh and everything is just in . <-- I meant that . (dot) xD how confusing of me

Fiachra
Posted on 01-01-14 05:46 PM Link | #37080
Can you try re-exporting the model and trying again, just in case?

If not can you PM me your model as there's not much more I can do without it, just copy and paste it into a spoiler, I don't need the textures.

Fiachra
Posted on 01-04-14 01:07 PM Link | #37208
R65 2014/01/04

- Texture Animation Editor totally rewritten, many improvements to functionality/stability, level corruption issues should all be removed, code much simpler and cleaner.
- Added option to generate texture animation scale, rotation and translation values given start and end values and number of values.
- Added 'Change Starting Lives' and 'Infinite Health' patches.

I had been meaning to rewrite the Texture Animation Editor for a while, the code was too complex and too hard to find bugs. It's now much simpler and the issues previously with the scale, rotation or translation values becoming corrupt and issues when adding and removing texture animations when there were multiple areas have been removed (after several hours turned out the problem was that certain addresses had to be multiples of 4).

Note:
When editing texture animations, changes are made to the level overlay as you edit, so if you don't want to keep them you must exit the Level Editor without saving. I probably won't change this as it greatly simplifiies the code involved.


Included in Additional Patches but included for reference

Change starting lives (99)
0x2AD08:
63

Infinite health
0x2A820:
22 0D A0 E3

Also, ROM's modified with SM64DSe do work with the GW3DS DS flashcart and therefore probably any other flashcart using the Wood firmware.

Download:
http://www.sendspace.com/file/3af3cw

skawo
Posted on 01-04-14 03:52 PM (rev. 4 of 01-04-14 03:55 PM) Link | #37214
So, I made a level using 2.1 and found a bug. Seems to also apply to the version in the post above.

Here's the situation:

I have a Bob-omb Buddy on Star 4. I want to place a JARIUSHI_L (arrow sign) on Star 2. When I do that, the Bob-omb Buddy on Star 4 gets removed from the list, and a Star 4 JARIUSHI_L is placed in the level instead. I think the Bob-Omb Buddy is the last on the object list, by the way.

If you need the ROM Patch to test this out, just drop a line on PM ;)

Stomatol
Posted on 01-04-14 04:58 PM Link | #37217
Posted by Fiachra
Also, ROM's modified with SM64DSe do work with the GW3DS DS flashcart and therefore probably any other flashcart using the Wood firmware.


Can confirm it works on Supercard DSTWO though.

Skelux
Posted on 01-09-14 07:55 AM Link | #37338
Is there any progress on replacing character models/textures? Even replacing the textures in any of the compressed archives causes the game to freeze. Could it be a problem with the way the archives are recompressed, or will I definitely need to go digging up some checksum code? Also, I know someone replaced Wario's texture, but that one was not compressed.
Pages: 1 2 3 4 5 ... 9 10 11 12 13 14 15 16 17 ... 27 28 29 30 31

Main - General SM64DS hacking - Editor development New reply

Page rendered in 0.029 seconds. (2048KB of memory used)
MySQL - queries: 26, rows: 144/144, time: 0.023 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.