Views: 20,349,997 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
05-26-24 03:38 PM

0 users reading CoinKiller -- NSMB2 editor upcoming | 1 bot

Main - NSMB2 hacking - CoinKiller -- NSMB2 editor upcoming Hide post layouts | New reply

Pages: 1 2 3 4 5 ... 19 20 21 22 23 24 25
Posted on 07-18-16 10:55 PM Link | #73920
er. i might as well recommend this old tutorial Sherry a.k.a Hypernova99 made.


Posted on 07-18-16 10:57 PM (rev. 2 of 07-19-16 09:58 PM) Link | #73922
Sry. Il tought you talked about coinkiller.

Nothing to say, so jadnjkfmnjamnfjkldnajfnjkanfjdksan jsdnvj m.

Posted on 07-18-16 10:58 PM Link | #73923
that didnt work for me..
any more suggestions?

Posted on 07-18-16 10:59 PM Link | #73924
Did you already try xKitten's tutorial?

Posted on 07-18-16 11:00 PM Link | #73925
yes, that was the first tut i tried

Posted on 07-19-16 10:36 AM Link | #73942
Posted by poudink

why are you posting rubbish?

Posted on 07-19-16 05:37 PM Link | #73952
Posted by poudink
Sry. Il talk you talked about coinkiller.

I believe he thought that he was talking about extracting Coinkiller, not the ROMFS.

Anyway, I helped him out and he has the ROMFS now. :P

Posted on 07-22-16 10:17 AM (rev. 4 of 07-22-16 12:24 PM) Link | #74294
Hi Mariomaster

Could you add some tooltip/status bar stuff like in Reggie! that tells you stuff like:
* what the object you are hovering is
* where it is
* how big is it (for tileobjs)
* what layer it is on (for tileobjs, unless sprites have a universal nybble for this)

Also, some corrections:
* jyotyu object 38 doesn't contain a 1-up mushroom - it contains a coin, unless you are invincible, then it contains a Super Star
* jyotyu object 29 reveals a coin underneath even if they are destroyed by non POW Block means

Posted on 08-03-16 08:31 PM Link | #75620
Can anyone provide me a compiled version for Linux? I get build error... :(

Posted on 08-03-16 08:35 PM (rev. 2 of 08-03-16 08:36 PM) Link | #75621

Posted by luigigamer
Can anyone provide me a compiled version for Linux? I get build error... :(

I'm not sure there is a Linux version(Or know how to compile a version for it)
Can't you use wine for Linux and run the pre-compiled .exe

Posted on 08-03-16 08:38 PM Link | #75622
No. It give me an error about Qt installation.

Posted on 08-03-16 08:42 PM Link | #75623
it would be helpful to give us details about that error

NSMBHD - Kafuka - Jul
melonDS the most fruity DS emulator there is


(post deleted) #75624

Posted on 08-24-16 09:28 PM (rev. 3 of 08-24-16 09:40 PM) Link | #76441
So I was working on this tileset:


I stuck it in the background suite copying S1_Kanaami and set 1-1 area 1 to use that as the background tileset (tileset 2). The editor displays the tiles as expected, but in-game all tileset 2 tiles are replaced with tileset 0 tiles.


Specifically, it appears to be using the object data of tileset 2, but pulling the tiles and behaviors from tileset 0.

EDIT: The tileset in question. Also is there any particular reason all S1 and S2 sarcs are 262kb (except one which is smaller)?

Posted on 08-25-16 04:34 PM Link | #76476
Alright, new thing. I'm just ignoring the other problem for now.

There is a random warp in my 1-1 that doesn't show up in the editor.

In-game screenshot:

Editor screenshot:

Posted on 08-25-16 07:16 PM Link | #76481

Bug reports go here or onto the GitHub issue tracker.

Anyways, the random warp happens because you actually placed a warp there. But if you place awarp, the size is 0x0 pixels by default. Since, yea, my visual representation is increadibly stupid and unfinished the size of the shown sprite is 0x0 as well :P

GitHub - YouTube - NSMBHD

Posted on 08-25-16 07:23 PM (rev. 2 of 08-25-16 07:55 PM) Link | #76482
Thanks for the link. I honestly don't know how I missed that thread seeing as it's in the first page on this forum. I'll post there from now on.

Anyway, I haven't placed any warps anywhere yet that I know of. Right now I'm just doing the basic layout of the level and haven't moved onto warps yet. But I might have done it on accident; I'll try highlighting the affected area and deleting everything there and see if it works.

EDIT: Attempting to delete the warp doesn't work.

Posted on 08-27-16 03:33 PM (rev. 3 of 08-27-16 07:13 PM) Link | #76542

After a very long time, I worked a bit on CoinKiller:

I added a translation manager which allows you to (who guessed it?) change the language of the editor. Not all text elements support translations yet tho.

Also you can now drag arround the current view with the middle mousebutton.

Lastly I added a button which updates your sprite data.

Download: https://kuribo64.net/get.php?id=w8VMAcY96VReAlqq

GitHub - YouTube - NSMBHD

Posted on 08-27-16 07:08 PM (rev. 2 of 08-27-16 07:08 PM) Link | #76549
That exe crashes on me with "The application was unable to start correctly (0xc000007b)."

Posted on 08-27-16 07:13 PM Link | #76550

I forgot adding QNetwork.dll.


GitHub - YouTube - NSMBHD
Pages: 1 2 3 4 5 ... 19 20 21 22 23 24 25

Main - NSMB2 hacking - CoinKiller -- NSMB2 editor upcoming Hide post layouts | New reply

Page rendered in 0.042 seconds. (2048KB of memory used)
MySQL - queries: 28, rows: 234/234, time: 0.010 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.