Kuribo64
Views: 7,617,738 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
10-23-17 04:33 PM
Guest:

0 users reading SM64DS Editor Help Thread - Post your questions here | 2 bots

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Pages: 1 2 3 4 5 ... 54 55 56 57 58 59 60 61 62
FireMario74
Posted on 11-13-16 10:42 PM Link | #79696
I got the key replaced and working perfectly :D. But I have one more issue, does anyone know how to delete the Mario hat that spawns on top of the key? Thanks!

Sparsite
Posted on 11-13-16 10:54 PM Link | #79697
Posted by FireMario74
I got the key replaced and working perfectly :D. But I have one more issue, does anyone know how to delete the Mario hat that spawns on top of the key? Thanks!


Fiachra would be the only one who would know how to do this. He gave me his BMD loading method a while back but even touching the registers of the function in the slightest bit crash the game.

The hat has no collision, so getting rid of only the model shouldn't be too hard. Maybe I could start digging through the behavior of the key and find out if there is some sort of loading method called.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Sparsite
Posted on 11-19-16 06:51 PM (rev. 3 of 11-19-16 07:33 PM) Link | #79785
How come decompressing all the overlays crashes the ROM after the boot logo on an R4 card?

EDIT: Nvm, I was just using an older wood firmware.


Erm... all my textures are invisible? What new bullshit model importing errors will sm64ds come.

How do I fix this?

[image]

It's looks perfectly fine in SM64DSe. I exported DAE from blender.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 11-20-16 03:53 PM Link | #79801
Posted by Sparsite
How come decompressing all the overlays crashes the ROM after the boot logo on an R4 card?

EDIT: Nvm, I was just using an older wood firmware.


Erm... all my textures are invisible? What new bullshit model importing errors will sm64ds come.

How do I fix this?

[image]

It's looks perfectly fine in SM64DSe. I exported DAE from blender.

Normals. Try flipping them. If your model is 2K or less, make a duplicate of everything and go to "Normals>Flip Normals" If not, just do above thing without duplicating

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 11-20-16 06:56 PM Link | #79816
Posted by pacmainia&luigi
Normals. Try flipping them. If your model is 2K or less, make a duplicate of everything and go to "Normals>Flip Normals" If not, just do above thing without duplicating


No clue where this "Normals>Flip Normals" button is.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 11-20-16 09:03 PM Link | #79818
Posted by Sparsite
No clue where this "Normals>Flip Normals" button is.

Tab into edit mode, Mesh>Normals>Flip Normals

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 11-20-16 09:23 PM Link | #79819
Posted by pacmainia&luigi
Tab into edit mode, Mesh>Normals>Flip Normals


It just flips the faces upside down. All it did was mess it up in the editor now.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 11-21-16 04:06 PM (rev. 2 of 11-25-16 10:26 AM) Link | #79827
Posted by Sparsite
It just flips the faces upside down. All it did was mess it up in the editor now.

Ah. This step worked for one of my models. does it stay the same if you import it in a different level?

I imported a strollin stu again. it is fine in the editor, crashes the game and the animation is screwed up. What happened? I can't find any btp files to go with it.

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 11-25-16 03:54 PM Link | #79923
Posted by pacmainia&luigi
Ah. This step worked for one of my models. does it stay the same if you import it in a different level?

I imported a strollin stu again. it is fine in the editor, crashes the game and the animation is screwed up. What happened? I can't find any btp files to go with it.


Yes, it's the same for every level.

As for the strollin stu, you shouldn't have to look for texture animations in the file system. If you click the replace model button, you will see all the texture animations by clicking the top right texture and BTP editor button. This can help you determine if it is texture animations or not.

Not sure how you would know that the animation is messed up because the game crashes, but I'm assuming you followed the on Fiachra's channel about replacing the Toad model with a Pianta. You might've failed to set the bones up correct.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Julian0555
Posted on 12-04-16 11:39 AM Link | #80113
I'm having an issue when importing a .obj into SM64DS Editor, Heres the error:
[image]

pacmainia&luigi
Posted on 12-23-16 04:11 PM (rev. 2 of 01-01-17 12:52 PM) Link | #80539
anyone know where the model for the background and Heave Ho is located?

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

mibts
Posted on 01-01-17 01:03 PM Link | #80690
Check enemy/popoi. I'm not sure.

____________________
Current hack: Excerpt from Super Mario 256

Any map on a flat torus can be colored with at most 7 colors.

Shane MGD
Posted on 02-02-17 12:16 AM Link | #81205
So the level importer on SM64DSe is screwing up my custom OBJ's I made when I import it. Is there something wrong I'm doing? Here's a side-by-side comparison of how it looks in SketchUp compared to how it looks when it's imported:
[image]
[image]

mibts
Posted on 02-03-17 10:40 PM Link | #81236
Triangulate all concave polygons.

____________________
Current hack: Excerpt from Super Mario 256

Any map on a flat torus can be colored with at most 7 colors.

pacmainia&luigi
Posted on 02-04-17 12:19 PM (rev. 2 of 02-20-17 12:01 PM) Link | #81248
WHEN IMPORTING, HIT THE "TRIANGULATE" BUTTON

does anyone have a 100% save for desmume? (.dsv format)

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

pacmainia&luigi
Posted on 03-26-17 01:51 PM Link | #82147
Uhhh... The model importer is being weird again. anyone know what's wrong?
[image]

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Shane MGD
Posted on 03-28-17 08:51 AM Link | #82176
The importer is always screwing up for me :/

mibts
Posted on 03-28-17 01:24 PM Link | #82177
Ooh, a classic. Did you import a DAE with normals? If so, you need to hex edit the bmd file to turn Light 0 on for the model. There's a more consistent method, but for now, search for 80 90 1f 00 xx xx 00 00 and replace it with 81 90 1f 00 xx xx 10 42. The former turns on light 0 and the latter gives the model a gray ambient color.

____________________
Current hack: Excerpt from Super Mario 256

Any map on a flat torus can be colored with at most 7 colors.

pacmainia&luigi
Posted on 03-28-17 06:43 PM Link | #82186
Posted by mibts
Ooh, a classic. Did you import a DAE with normals? If so, you need to hex edit the bmd file to turn Light 0 on for the model. There's a more consistent method, but for now, search for 80 90 1f 00 xx xx 00 00 and replace it with 81 90 1f 00 xx xx 10 42. The former turns on light 0 and the latter gives the model a gray ambient color.

Weird thing is, I did it on a different version of the editor and replaced kinopio instead of penguin, and it worked fine.

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Hiccup
Posted on 04-15-17 06:20 AM (rev. 2 of 04-15-17 07:20 AM) Link | #82501
1. Is there a recommended unit to use in sketchup for SM64DS models?

2. Is there info on how large objects (e.g. Mario, different sized blocks) are, so that sketchup models can be made to the right size?

3. How do you prevent textures in imported models appearing darker than they should be (I feel like I've already asked this but I can't find it.

edit: it seems that 1x1x1 (in inches) is the size of the pushable block...
Pages: 1 2 3 4 5 ... 54 55 56 57 58 59 60 61 62

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Page rendered in 0.051 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 234/234, time: 0.036 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2015-10-07)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.