Views: 11,214,148 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
09-28-20 05:39 AM

0 users reading Multi-Channel bcstm help | 1 bot

Main - NSMB2 hacking - Multi-Channel bcstm help New reply

Posted on 10-17-16 02:57 PM (rev. 2 of 10-17-16 03:00 PM) Link | #78870

I am working on importing a custom multi-channel bcstm into nsmb2, but there is some slight issues with the looping of the music I have been un-able to fix.

Music in game:

Bug is present at around 50sec into the video.

But if I play the music in audacity it is a perfect loop.
Someone please explain what I am doing wrong. (Or even better provide me with a wav to bcstm converter that supports both multi-channel and looping)

Posted on 10-17-16 03:33 PM Link | #78872
I can't even hear the glitch to be honest. Although if its not looping correctly just google a converter and use it, and if it has the same problem, try another converter, and if it has the problem use another one, etc.


Sorry for the maintenance -- we'll be back soon!

Posted on 10-17-16 03:48 PM Link | #78874

The problem is, there isn't any converter that does wav -> bcstm while allowing multi channel + loop points(that I know of)

Posted on 10-17-16 06:56 PM (rev. 2 of 10-17-16 07:00 PM) Link | #78885
How about going from .wav to multi-channel .brstm to .bcstm?

It sounds like there is a pause right before the loop at 0:54. Perhaps there is a channel that's slightly longer than another channel, so the game thinks that pause is part of the music and then loops it.

Posted on 10-17-16 10:03 PM Link | #78893
All of the channels are the same length, it's just NSMB2's way of looping. We can try that thing about converting to brstm, then bcstm.

I hack games, then I play them!

Posted on 10-18-16 02:26 AM Link | #78897
Are you just looping it from end of the file to beginning? If so, that problem shouldn't occur. If you set custom loop points then good luck with that. Always bugs for me too. Sometimes I just get some distorted weird beeping sound and sometimes the loop just won't start where I set it.

Check out my Patreon Page if you want to support me :)

Posted on 10-18-16 03:32 AM Link | #78898

I tried setting loop points at first, but that failed. So I decided to try looping from start to finish, still the same problem occurs.

Posted on 10-19-16 08:11 PM (rev. 2 of 10-19-16 08:12 PM) Link | #78954
I have fixed this problem, and it requires setting offset 0x61 in the BCSTM to 0x01. For some reason the converter misses this. It sets the looping start and end right, but it doesn't apply the flag whether to loop or not (0 = don't loop, 1= loop).


Main - NSMB2 hacking - Multi-Channel bcstm help New reply

Page rendered in 0.031 seconds. (2048KB of memory used)
MySQL - queries: 28, rows: 208/208, time: 0.023 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.