Views: 10,935,087 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
07-03-20 08:33 AM

0 users reading Magical Adventures of Technology hating me | 1 bot

Main - Computers and technology - Magical Adventures of Technology hating me New reply

Posted on 11-22-15 09:20 PM Link | #65834
First of all, some background:
My brother, who works on desk-side tech support, has a beast 3-monitor setup with raid 0 SSDs. If you don't know what that means, file reading/writing is FAST. And i'm just sitting here with my 5200 RPM (slow) 1TB hard drive that has been used more than any hard drive ever should be, and I'm not very good at maintaining.

The one thing holding me back was that I liked having a 1TB hard drive, and it just didn't feel necessary. But, I spent the $100 and got a 240 GB SSD, along with a hard drive enclosure.

I got a few pictures of the manual for my laptop, and then as soon as the SSD arrived, I went to work on disassembling my laptop. I had disassembled consoles and controllers before, and my brother let me use his i-fixit toolkit, so I didn't think it would be that hard to disassemble.

Laptops are pretty annoying to take apart in general, and Lenovo laptops in particular are annoying as hell to take apart. But, I eventually got it and my brother helped me swap the hard drive with the new SSD. I'm not going super in detail here, but it's probably worth noting that you need a super-thin screwdriver to pop out the keyboard, and applybrute force with a flat-head to get to the hard drive.

I'm pretty lucky, because since my brother works on desk-side support, so I had access to special tools. Windows 7 PE, in particular, is what I used to make an image of my hard drive, and restore it to the new SSD.

In Windows 7 PE the SSD was detected.
In the legacy method of booting in the bios, the SSD was detected. BUT, this is Windows 10. Windows 8-10 require you to use UEFI, and trying legacy just doesn't work.

Here's the problem that caused a week of troubleshooting:
In UEFI, the SSD was not detected. We (as in me and my brother) tried updating the bios, changing settings in the bios, and many other things. In the UEFI mode of the bios, the SSD could never detect.

We never got it fixed. Instead, we installed Ubuntu 14 via the "special tools" that I mentioned earlier.

So, I'm a Linux boy now. As a former mac user, I am NOT relying on Wine for running Windows programs. I've already set up a Windows 7 Virtual Machine.

I just wanted to share this, and I'm kind of wondering what other people's experiences have been like.

Website | Twitter

Posted on 01-24-16 06:34 PM (rev. 2 of 01-24-16 07:12 PM) Link | #67198
I'm starting to miss a few Windows exclusive games (that are unplayable in a VM/with Wine), so I decided to dual boot Windows 7 alongside Ubuntu, onto my external hard drive. I spent the better half of a day trying to figure out why the Windows 7 installer wasn't accepting my external, only to find out that I had to reformat it to MBR instead of GPT.

But, it still wouldn't accept my external. I found out that the setup doesn't allow you to install to a USB device. YAY.

Apparently, you can use imagex, bcdboot, and bootsect, but the script complains about missing DLLs.
(this is XP PE, booted from a flash drive. 7 PE complains about ureg.dll)

I tried the same method, except manually from the command line.
That looked like it worked, since I didn't get any error messages, but when trying to boot from my external, I get
error:file 'grub/i386-pc/normal.mod" not found
.(no picture, sorry.)

When I changed Legacy to UEFI in the BIOS, nothing was recognized, and when I reverted that change, in Ubuntu, I could no longer change the back lighting for my laptop's monitor using the keys on my keyboard.

Now, I guess I'll reformat and try WinToUSB. It seems pretty sketchy, but I'm really running out of options...

As for the brightness, it's actually a bug that happened in Windows 8/10, which I fixed by changing the graphics drivers, and not touching the brightness buttons. Once I switched to Ubuntu, this never happened until not, which is weird...


The flash drive I was booting Win7 PE and WinXP from got overwritten while I was trying the first method, so I have no way to run WinToUSB. And I broke my brother's flash drive.

Just because technology doesn't hate me enough, now my 2nd monitor is at the wrong resolution.
That's been happening randomly on startup ever since I upgraded from Ubuntu 13.10 to 15.10.

Website | Twitter

Posted on 01-25-16 03:22 AM Link | #67212
Good luck trying to survive on Linux lol. Tried it a few years ago, things didn't work when they had to and I just started booting into Windows more and more until I just dumped Ubuntu all together.

It's fun and games in the beginning but it gets old rather quick :p


Posted on 02-04-16 03:46 PM (rev. 2 of 02-04-16 06:43 PM) Link | #67520
For me, Linux is really starting to lose it's charm, mainly because of compatibility.

So, here's my plan:
- Back up EVERYTHING to the External Hard Drive.
- Torrent LEGALLY obtain a Windows 7 ISO.
- Use winusb (Linux tool) to get the Windows 7 installer onto my flash drive.
- Boot into the flash drive.
- Format SSD from installer, then install Windows.
- Maybe upgrade to Windows 10.(bye bye privacy)

EDIT:hello from Windows 7 :D

Website | Twitter

Posted on 02-04-16 09:32 PM Link | #67536
Ayy. Since we're on the topic (kind of), does anybody know how to downgrade from Windows 8 to 7?

Kuribo64 / NSMBHD / MMM

NNID: GreenThunder1337
3DS FC: 1521 - 5979 - 1511

Posted on 02-04-16 09:38 PM (rev. 2 of 02-04-16 10:23 PM) Link | #67537
That would involve reinstalling the OS. AFAIK, you would boot to the installation media for Windows 7, and install 7 to your main storage device , that Windows 8 is on.

Since your main storage device already has an operation system, I would suggest backing everything meaningful to a flash drive or whatever, and when you run the installation media, format your main storage device (this is called a clean install), if that makes sense.

Website | Twitter

Posted on 02-05-16 07:21 AM Link | #67542
I recommend making a second hard drive partition, and from there install windows 7. That'll keep your files where you left them, and give you thr OS to see if you like it. I personally do this with Windows 7/10, but I mainly use 10.

Switch on latest firm happily playing Smash daily
PC with an i7-4790K, RX480, 16GB ram
Various other consoles that are hardly used due to emulation existing

Posted on 02-05-16 08:56 AM Link | #67546
The thing with that is, you have to format your hard drive, which will get rid of all of your files, so you need something to backup your files to.

If you do have something to backup to, it wouldn't hurt to do that if you want to dual boot.

Website | Twitter

Posted on 02-06-16 07:46 AM Link | #67557
You don't. You can partition your hard drive and install Windows 7 separately. If you wish to get rid of 8 completely later on, you can just delete the Windows 8 partition and merge the free space with the one from 7.


Posted on 03-05-16 08:56 PM (rev. 2 of 03-05-16 10:40 PM) Link | #68277
Whenever I make A QFileDialog in Qt, Qt shows this message in the console:
shell\comdlg32\fileopensave.cpp(9456)\comdlg32.dll!750C0750: (caller: 750B3458) ReturnHr[PreRelease](1) tid(164) 80070490 Element not found.

Which, gets annoying after a while, because it brings up the "Application Output" tab, obscuring some of the code.

The file dialogs are still fully functional, it's just that whenever I run a program using them, made by me or not, it always prints that error to the console.
tldr: File dialogs are printing errors.

A google search for shell\comdlg32\fileopensave.cpp shows a Chinese bug report (?) and someone with the same problem on a Windows Dev subreddit, not using Qt. So, it's a Windows 10 problem

sfc /scannow reports that there are corrupted that can't be fixed. I've had this Windows 10 installation for a month, and have properly maintained it (no adware/viruses/whatever), so I'm not really sure what happened here :P

I read that you could use the DISM command to fix this (DISM /Online /Cleanup-Image /RestoreHealth), but that complained about missing source files. Now, I'm downloading a Windows 10 ISO, using the Media Creation Tool.

EDIT: Well, QFileDialog still prints an error to the console. On the bright side, according to sfc, the corrupted files are fixed.

I'm almost definite that this is a problem with Windows 10, so thanks, Microsoft :P

Website | Twitter

Main - Computers and technology - Magical Adventures of Technology hating me New reply

Page rendered in 0.095 seconds. (2048KB of memory used)
MySQL - queries: 29, rows: 217/217, time: 0.079 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.