Kuribo64
Views: 9,835,187 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
08-24-19 08:30 PM
Guest:

0 users reading SM64DS Editor Help Thread - Post your questions here | 3 bots

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Pages: 1 2 3 4 5 ... 26 27 28 29 30 31 32 33 34 ... 61 62 63 64 65
Jesse
Posted on 12-02-14 08:14 AM Link | #52148
I also got a texture import problem, The all mesh joining tip worked btw. But when I import my map now everything looks fine in the importer. but when I play it all the textures are black. this didn't happen when I had seperated mesh, because then I saw random mesh with a imported texture applied on that.

Besides all of that I got a main rom problem which is that everytime I import a level in bob-ombs battle field or another level, some levels will crash. but not the imported once. Like I imported in bob-omb battle field a level and I cannot go to peaches room to change player.
Skelux actually told me once a "fix" but I didn't get it

[17:54:21] jesse: sounds a little bit like my problem, importing one level and another level crashes
[17:54:37] jesse: it seems that there are unstable levels in the game
[17:55:18] SKELUX: you can fix some of them by manually fixing anomalies in the level script
[17:55:42] SKELUX: like the second test level

Fiachra
Posted on 12-02-14 09:52 AM Link | #52153
I just noticed the DAE black textures myself; the issue occurs when the model has normals defined. I don't know why as normals are working fine in IMD. I'm just going to disable them for DAE.

I'm about to (today) release an update which finally fixes the issue where the camera is irreversibly messed up after importing a level from an XML. This will allow you to export all your levels and re-import them from XML over a clean ROM.

Stomatol
Posted on 12-02-14 11:32 AM Link | #52158
So uh, tried importing an IMD model and got this error;


[image]

Any clue on what I might have done wrong? Seems like it has to with KCL, since the model itself imported fine but I got another error when tring to open the KCL editor afterwards

Fiachra
Posted on 12-02-14 01:43 PM Link | #52160
Jesse and Stomatol: Should be fixed, please try the latest version, details.

SuperMario64DS
Posted on 12-02-14 02:34 PM Link | #52164
Posted by Fiachra
What did you do to get it working?


What do you mean when you say that, exactly?

Fiachra
Posted on 12-02-14 03:11 PM Link | #52167
Posted by SuperMario64DS
What do you mean when you say that, exactly?


You said:
Posted by SuperMario64DS
(A solution to the previous was discovered, and was deleted in error) ...


What did you change in your model to allow you to successfully import over the Castle ground floor?

To answer your deleted question, I don't know how a level is set to use snow. There appears to be an AR code that allows you to turn it on so I'll look at that, it's probably possible to make a patch to enable it.

SuperMario64DS
Posted on 12-02-14 03:28 PM (rev. 5 of 12-02-14 03:54 PM) Link | #52171
Posted by Fiachra
What did you change in your model to allow you to successfully import over the Castle ground floor?


Oh, okay.

The mesh is rigged to several bones - r0-node, r1-node, r2-node, etc. Anything linked to r0-node will appear by default.

To trigger the rendering of anything linked to other portions of the model, you set the in/out area's value of the door to that of the bone. So, if you'd like a door to render area 2 (Mesh linked to r2-node) when you enter, you set the in value to 2. To render are 7 when you leave that door (r7-node), then set out value to 7. I'd imagine that it only can up to 255.


Edit: It would appear as if I were mistaken, the name the mesh/group plays a role as well. I'll arrange an explanation once I've have it sorted out.

Jesse
Posted on 12-02-14 03:57 PM Link | #52177
yush that would be awesome for gruntilda's lair since its giant.

SuperMario64DS
Posted on 12-02-14 05:59 PM Link | #52186
It turns out it's slightly more complicated than I figured. I'll make a thread on it.

DarkBones64
Posted on 12-15-14 01:08 PM Link | #52753
Out of curiosity, is it possible to make it so you don't have a star select screen like the castle secret stars, but still have multiple stars in the level (effectively making the level stay the same for every star)? I pretty much ask out of curiosity, as I probably wouldn't finish a SM64DS hack even if I started...

Fiachra
Posted on 12-15-14 03:09 PM Link | #52754
Yes, there's no issue having multiple stars like that, it's done in the original game.

Stomatol
Posted on 12-19-14 10:00 AM Link | #52832
So I get this black texture problem when importing OBJ models with normals as well;


[image]

Works fine when exporting without normals though

Fiachra
Posted on 12-19-14 03:40 PM Link | #52839
Posted by Stomatol
So I get this black texture problem when importing OBJ models with normals as well;


[image]

Works fine when exporting without normals though


I'm not sure why that happens. I don't know what's different between the normals in OBJ and IMD; they're both read in and stored the same and they appear to be the same format. I'm just going to disable normals for OBJ until it's ever worked out. There's not really any benefit to having them in OBJ anyway.

Jesse
Posted on 01-02-15 12:22 PM Link | #53707
My rom is still crashing when importing a big level over bob-ombs battle field. The whole rom! You seem to use levels with much textures and polygons, So I would guess I would just work. Or is it normal that this happens?

Fiachra
Posted on 01-02-15 01:46 PM Link | #53715
If the whole ROM's crashing and B.O.B. is the only level you've modified then it must be corrupt. If you can open the level in the editor, you can export it as XML and import it into a new ROM.

Jesse
Posted on 01-03-15 08:40 AM Link | #53749
I have not only modified B.O.B. but also shifting sand land. When I import a (oversized) level in B.O.B. the game is already half crashing. I mean that you cannot visit some levels anymore because they will crash. You can also not go to peaches room. And when I import another Not oversized level, the game will crash totally.

I use the 0022 - Super Mario 64 DS (E)(Wet 'N' Wild) rom. Is that a wrong rom?

Fiachra
Posted on 01-03-15 10:40 AM Link | #53750
That shouldn't happen. If B.O.B.'s model is too large only that level should be affected. Can you try importing again in a clean ROM. Yes, "0022 - Super Mario 64 DS (E)(Wet 'N' Wild)" is correct.

Jesse
Posted on 01-03-15 01:02 PM (rev. 2 of 01-03-15 01:02 PM) Link | #53759
I am pretty sure the rom is not corrupt.

- I imported a level with two textures. Nothing happened.
- Then I imported a level with more textures which loads more then 48k in the vram. Other levels crashes but the imported level works fine.
- Then I imported the two textured model again and everything was working fine again.

The odd thing is that some levels crash and some not. Like lethal lavaland and peaches room crashes. but shifting sandland and B.O.B. never crash.

This was all done in a clean rom yes.

Fiachra
Posted on 01-04-15 07:21 AM Link | #53814
I've never come across that issue before and I have no idea as to why it might be happening. You may just need to reduce the textures in your model and try again.

SGC
Posted on 01-24-15 11:27 AM Link | #55113
When i import a model the textures are all upside-down why is this happening?

____________________
MKDS Hacking & Modding Discord:
https://discordapp.com/invite/CAktUYP
Pages: 1 2 3 4 5 ... 26 27 28 29 30 31 32 33 34 ... 61 62 63 64 65

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Page rendered in 0.036 seconds. (2048KB of memory used)
MySQL - queries: 28, rows: 145/145, time: 0.028 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.