Kuribo64
Views: 6,635,672 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
02-19-17 11:40 AM
Guest:

0 users reading SM64DS Editor Help Thread - Post your questions here | 2 bots

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Pages: 1 2 3 4 5 ... 54 55 56 57 58
FireMario74
Posted on 11-13-16 10:42 PM Link | #79696
I got the key replaced and working perfectly :D. But I have one more issue, does anyone know how to delete the Mario hat that spawns on top of the key? Thanks!

Sparsite
Posted on 11-13-16 10:54 PM Link | #79697
Posted by FireMario74
I got the key replaced and working perfectly :D. But I have one more issue, does anyone know how to delete the Mario hat that spawns on top of the key? Thanks!


Fiachra would be the only one who would know how to do this. He gave me his BMD loading method a while back but even touching the registers of the function in the slightest bit crash the game.

The hat has no collision, so getting rid of only the model shouldn't be too hard. Maybe I could start digging through the behavior of the key and find out if there is some sort of loading method called.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Sparsite
Posted on 11-19-16 06:51 PM (rev. 3 of 11-19-16 07:33 PM) Link | #79785
How come decompressing all the overlays crashes the ROM after the boot logo on an R4 card?

EDIT: Nvm, I was just using an older wood firmware.


Erm... all my textures are invisible? What new bullshit model importing errors will sm64ds come.

How do I fix this?

[image]

It's looks perfectly fine in SM64DSe. I exported DAE from blender.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 11-20-16 03:53 PM Link | #79801
Posted by Sparsite
How come decompressing all the overlays crashes the ROM after the boot logo on an R4 card?

EDIT: Nvm, I was just using an older wood firmware.


Erm... all my textures are invisible? What new bullshit model importing errors will sm64ds come.

How do I fix this?

[image]

It's looks perfectly fine in SM64DSe. I exported DAE from blender.

Normals. Try flipping them. If your model is 2K or less, make a duplicate of everything and go to "Normals>Flip Normals" If not, just do above thing without duplicating

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 11-20-16 06:56 PM Link | #79816
Posted by pacmainia&luigi
Normals. Try flipping them. If your model is 2K or less, make a duplicate of everything and go to "Normals>Flip Normals" If not, just do above thing without duplicating


No clue where this "Normals>Flip Normals" button is.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 11-20-16 09:03 PM Link | #79818
Posted by Sparsite
No clue where this "Normals>Flip Normals" button is.

Tab into edit mode, Mesh>Normals>Flip Normals

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 11-20-16 09:23 PM Link | #79819
Posted by pacmainia&luigi
Tab into edit mode, Mesh>Normals>Flip Normals


It just flips the faces upside down. All it did was mess it up in the editor now.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 11-21-16 04:06 PM (rev. 2 of 11-25-16 10:26 AM) Link | #79827
Posted by Sparsite
It just flips the faces upside down. All it did was mess it up in the editor now.

Ah. This step worked for one of my models. does it stay the same if you import it in a different level?

I imported a strollin stu again. it is fine in the editor, crashes the game and the animation is screwed up. What happened? I can't find any btp files to go with it.

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 11-25-16 03:54 PM Link | #79923
Posted by pacmainia&luigi
Ah. This step worked for one of my models. does it stay the same if you import it in a different level?

I imported a strollin stu again. it is fine in the editor, crashes the game and the animation is screwed up. What happened? I can't find any btp files to go with it.


Yes, it's the same for every level.

As for the strollin stu, you shouldn't have to look for texture animations in the file system. If you click the replace model button, you will see all the texture animations by clicking the top right texture and BTP editor button. This can help you determine if it is texture animations or not.

Not sure how you would know that the animation is messed up because the game crashes, but I'm assuming you followed the on Fiachra's channel about replacing the Toad model with a Pianta. You might've failed to set the bones up correct.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Julian0555
Posted on 12-04-16 11:39 AM Link | #80113
I'm having an issue when importing a .obj into SM64DS Editor, Heres the error:
[image]

pacmainia&luigi
Posted on 12-23-16 04:11 PM (rev. 2 of 01-01-17 12:52 PM) Link | #80539
anyone know where the model for the background and Heave Ho is located?

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

mibts
Posted on 01-01-17 01:03 PM Link | #80690
Check enemy/popoi. I'm not sure.

____________________

It's impossible to hit the exact center of a dart board with the exact center of the tip of a dart. Since there are an infinite amount of points on the dart board, the probability of doing that is 1/infinity. There's always room for improvement.

Shane MGD
Posted on 02-02-17 12:16 AM Link | #81205
So the level importer on SM64DSe is screwing up my custom OBJ's I made when I import it. Is there something wrong I'm doing? Here's a side-by-side comparison of how it looks in SketchUp compared to how it looks when it's imported:
[image]
[image]

mibts
Posted on 02-03-17 10:40 PM Link | #81236
Triangulate all concave polygons.

____________________

It's impossible to hit the exact center of a dart board with the exact center of the tip of a dart. Since there are an infinite amount of points on the dart board, the probability of doing that is 1/infinity. There's always room for improvement.

pacmainia&luigi
Posted on 02-04-17 12:19 PM Link | #81248
WHEN IMPORTING, HIT THE "TRIANGULATE" BUTTON

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........
Pages: 1 2 3 4 5 ... 54 55 56 57 58

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Page rendered in 0.054 seconds. (2048KB of memory used)
MySQL - queries: 27, rows: 220/220, time: 0.034 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2015-10-07)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.