Kuribo64
Views: 6,735,527 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
03-24-17 05:53 PM
Guest:

0 users reading SM64DS Editor Help Thread - Post your questions here | 1 bot

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Pages: 1 2 3 4 5 ... 51 52 53 54 55 56 57 58
Sparsite
Posted on 08-19-16 09:51 PM Link | #76320
I know its not sm64ds specific, but whenever I apply a .xdelta patch for sm64ds rom hacks, it gives me "xdelta3: target window checksum mismatch: XD3_INVALID_INPUT"

Patch is obviously the .xDelta file, tried source as a vanilla EUR SM64DS, didn't work, opened it in sm64dse, still get the same error. Path name is "blahblah.nds"

Patches are the reasons we can't have nice things.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Fiachra
Posted on 08-20-16 05:24 AM Link | #76326
Have you tried taking a clean ROM, patching it in SM64DSe and then trying to apply the xDelta patch? If that doesn't work you'll need to ask the author exactly what "source" ROM he used or else to generate a new patch properly.

Sparsite
Posted on 08-20-16 03:31 PM Link | #76332
happened with your deku link hack, which I know you use eur. And yes, I tried a clean rom, but it didnt work, so I opened it in sm64dse, and it gives the same error. Not exactly sure what it means, but I got the same error with the two star land xdelta patches, and another hack, cant remember the name of it.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 08-22-16 09:55 AM (rev. 2 of 08-23-16 08:57 PM) Link | #76383
Posted by Fiachra
It could still be the normals. Does your OBJ model contain "vn" commands?

never mind. I expoted the model as DAE in the editor and re imported it and did step 2.

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 08-30-16 02:59 AM Link | #76666
I've never been able to successfully open any of the GUI bin files. Always gives me an index was out of bounds array error.

Scale: 1.6
Decompress = true
NCG: data/2D_cad/d_2d_game_over_ncg.bin
NCL: data/2D_cad/d_2d_game_over_ncl.bin
NSC: data/2D_cad/d_2d_game_over_BG_ncg.bin
Width and height: 256x256
bits per pixel: 4
palette row: 4
Is Minimap = false
128x128 = true

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Sparsite
Posted on 09-11-16 09:26 AM (rev. 2 of 09-11-16 09:29 AM) Link | #77119
Ok, update: I found using NSMBe is a million times easier and better than using SM64DSe's minimap editor. (I think Fiachra should just fork the NCG/NCL code from NSMBe.)

1. Open your ROM in NSMBe
2. Double-click on an NCG file
3. Go back to the main NSMBe window and click on corresponding palette (currently documenting for file system documentation)
4. Click LZ Compress
5. Double click the palette
6. Click add all
7. Go to the window with the NCG open and check "View in 4pbb"
8. Go through the palettes at the side (should only take about 5 seconds)

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Fiachra
Posted on 09-11-16 03:48 PM Link | #77128
Posted by Sparsite
I've never been able to successfully open any of the GUI bin files. ...

http://kuribo64.net/board/thread.php?pid=62530#62530
http://kuribo64.net/board/thread.php?pid=62384#62384

Under "Images, icons, fonts etc." in the "Getting Started" tutorial.

Sparsite
Posted on 09-11-16 04:17 PM (rev. 2 of 09-11-16 04:17 PM) Link | #77131
Posted by Fiachra


Well, of course I've read those. It just never worked and always threw an unhandled exception, so I used NSMBe.

Anyways, any idea why my textures look darker in-game?
[image]

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 09-11-16 04:31 PM Link | #77132
Posted by Sparsite
Anyways, any idea why my textures look darker in-game?
[image]

It could be the vertex colors.

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 09-11-16 04:34 PM Link | #77134
Posted by pacmainia&luigi
It could be the vertex colors.


I imported as obj so there can't be vertex colours.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Platinatic
Posted on 09-12-16 04:01 PM Link | #77196
Lighting maybe?
I think (but i'm not too sure) that MKDS also has this because of the lighting.

Sparsite
Posted on 09-13-16 05:49 PM (rev. 2 of 09-13-16 05:50 PM) Link | #77270
Posted by Platinatic
Lighting maybe?
I think (but i'm not too sure) that MKDS also has this because of the lighting.


I don't really care whats causing it, I just wanna fix it so my stage doesn't look trashy. (Theres no known way to edit lighting, would probably require rewriting some shit in the level graphical settings.)

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 09-16-16 07:57 PM Link | #77497
Posted by Sparsite
I don't really care whats causing it, I just wanna fix it so my stage doesn't look trashy. (Theres no known way to edit lighting, would probably require rewriting some shit in the level graphical settings.)

Maybe its just the editor being weird/glitchy. I was Importing a level i made and some of the textures colors got messed up. I can't remember how I fixed it, though.

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 09-16-16 08:04 PM Link | #77500
Posted by pacmainia&luigi
Maybe its just the editor being weird/glitchy. I was Importing a level i made and some of the textures colors got messed up. I can't remember how I fixed it, though.


Probably.

Been looking at graphical settings to try and fix this.

02044968 - Affects Shading (with NOP)

02044B30 - Beginning of some sort of texture function
02044B48 - Set Polygon Attributes
02044B4C - DIF_AMB - MaterialColor0 - Diffuse/Ambient Reflect (40004C0h)
02044B58 - SPE_EMI - MaterialColor1 - Specular Ref. & Emission (40004C4h)
02044B64 - Set Texture Palette Base Address (40004ACh)
02044B70 - Set Texture Parameters (40004A8h)
02044BA8 - End of some sort of texture function

02044D7C - Set Texture Coordinates of some sort

I'll probably make a thread for hardware settings soon.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 09-16-16 08:08 PM (rev. 2 of 09-17-16 10:20 AM) Link | #77502
I can't quite understand how to replace the image for the title screen. I don't get what to do after I locate the image in the hex editor.
Can someone please clarify? i'm trying to import this image:[image]

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 09-17-16 11:53 AM Link | #77526
Posted by pacmainia&luigi
I can't quite understand how to replace the image for the title screen. I don't get what to do after I locate the image in the hex editor.
Can someone please clarify? i'm trying to import this image:[image]


Posted by Fiachra
There's no set format for overlays - they can contain anything in no particular structure.

In the case of the title images; you need to first use the minimap editor;
- The minimap editor doesn't let you work with overlays so you need to import the title image over some existing image (any).
- The image must be 256x192 pixels, BPP is 8, neither the NCG nor NSC files should be compressed. The first colour in the palette should be the (transparent) background colour.
- Import image.
- Export the imported image files (NCG, NCL and NSC).
- Decompress and export overlay 7.
- You then use a hex editor to overwrite the content of overlay 7 at the addresses specified here with the contents of the exported images.
- Import the modified overlay over the original.




____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

pacmainia&luigi
Posted on 09-17-16 07:13 PM Link | #77558
Posted by Sparsite

Ah. Thanks!

____________________
Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka.........

Sparsite
Posted on 09-24-16 10:28 PM (rev. 3 of 09-24-16 10:29 PM) Link | #77966
I swear to fucking god im going to murder somebody.

The lighting was a bad enough problem, but this is a whole new level of retarded.

How does this texture (64x64): [image]

go to this ingame???:
[image]

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP

Platinatic
Posted on 09-25-16 06:16 AM Link | #77971
Maybe it has too many colours, so the game tried to reduce the amount of colours in some way.
If that's not it, then i don't know.

Sparsite
Posted on 09-25-16 10:11 AM Link | #77974
Posted by Platinatic
Maybe it has too many colours, so the game tried to reduce the amount of colours in some way.
If that's not it, then i don't know.


perhaps, but that texture ingame is only abour 2 colors, so I doubt the game would knock it down that much.

____________________
ASMR:
*quietly whispers*
move r0 r7
push r4 to r14
load register r4 into r0
POP
Pages: 1 2 3 4 5 ... 51 52 53 54 55 56 57 58

Main - General SM64DS hacking - SM64DS Editor Help Thread - Post your questions here New reply

Page rendered in 0.028 seconds. (2048KB of memory used)
MySQL - queries: 26, rows: 227/227, time: 0.017 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2015-10-07)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.