Views: 8,813,077 Home | Forums | Uploader | Wiki | Object databases | IRC
Rules/FAQ | Memberlist | Calendar | Stats | Online users | Last posts | Search
10-15-18 11:24 PM
Guest:

0 users reading Flip-Swap Panel not flipping | 1 bot

Main - Archived forums - General SMG hacking - Flip-Swap Panel not flipping New reply


Yosheano
Posted on 12-05-13 07:39 AM (rev. 2 of 12-05-13 07:39 AM) Link | #35676
I'm currently in the process of making my own level for SMG2 using the template made by MrRean.
I have added in a couple of Flip-Swap Platforms, but for some reason when Mario/Luigi Spins the platforms don't switch. I also copied the properties exactly(eg. Obj_args)(except the object ID) from one of the flip-swap platforms from the original Flip-swap galaxy.
Does anyone know why they're not flipping?

skyl
Posted on 12-05-13 07:44 AM Link | #35678
There should be random floating blue cubes off the edge and up in the original FlipSwap. I think it needs one of those, it's some kind of spin controller.

____________________
Can you burn a Luigi board?

Yosheano
Posted on 12-05-13 08:29 AM (rev. 2 of 12-05-13 08:34 AM) Link | #35680
I tried adding it in (I'm assuming the object your referring to is called Reverse Sync Switch) and replicating its properties from the original flip swap but it didn't seem to change anything.

MK7tester
Posted on 12-05-13 10:29 AM Link | #35685
No, it's an Area, you need to use SpinSwitchArea

Yosheano
Posted on 12-05-13 11:19 AM (rev. 2 of 12-05-13 12:18 PM) Link | #35686
Posted by Silver
No, it's an Area, you need to use SpinSwitchArea


Thanks. I've just added it in but the game crashes when i try to load the level.
According to the Object database SpinSwitchArea is linked via SW_A. Does this mean that if the flip switch panels' SW_A=10, then that the SpinSwitchArea's SW_A=9 (or is it 10/11)? Also, does it need to have a certain x/y/z away from the flip switches? and finally will it not work if i insert it into the general objects section and it needs to be in another section such as Gravity?


Edit: I've been looking into the galaxies that supposedly contain SpinSwitchArea according to the object database. But i can't find it in any of them.

Jesse
Posted on 12-05-13 12:35 PM Link | #35687
area's doesn't have to be in the object data base right?

Yosheano
Posted on 12-05-13 01:11 PM Link | #35689
Posted by jjesss064
area's doesn't have to be in the object data base right?


I think you might have got the wrong end of the stick. I can't find the object SpinSwitchArea in any galaxy. But according to the object database on this site. there are at least 4 galaxies that contain SpinSwitchAres

shibboleet
Posted on 12-05-13 03:30 PM Link | #35691
Add a SpinSwitchArea in AreaObjInfo
Set it's SW_A to 9
Give it an AreaShapeNo of 0

Add a RedBlueTurnBlock with a SW_A of 9.

____________________
a

Yosheano
Posted on 12-06-13 06:14 AM (rev. 3 of 12-06-13 07:50 AM) Link | #35715
Posted by Luigi
Add a SpinSwitchArea in AreaObjInfo
Set it's SW_A to 9
Give it an AreaShapeNo of 0

Add a RedBlueTurnBlock with a SW_A of 9.


what/where is AreaObjInfo.


By the way i'm using whitehole and not anarchy if it makes any difference to the solution.

EDIT: just updated to whitehole v1.2 and i can see the SpinSwitchArea object under "Areas" (in the original Flip-Switch) but i can't seem to add it in to my level as when i go to add the object in, there is no option to add it in to the "Areas" Category. When i found SpinSwitchArea in ChompWorks, it's SW_A appeared to equal "".

EDIT2: Just realised that i can't add SpinSwitchArea without Anarchy. I think i've got it sorted now.
Does it need to be a certain size or a certain place, or can it be put anywhere?


Main - Archived forums - General SMG hacking - Flip-Swap Panel not flipping New reply

Page rendered in 0.028 seconds. (2048KB of memory used)
MySQL - queries: 27, rows: 209/209, time: 0.020 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2018-07-20)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.